Portfolio (#7) - ModH264Streaming issues (IIS7 32bit) (#253) - Message List

ModH264Streaming issues (IIS7 32bit)
 solved
 locked

Hi,

I can not get the ModH264Streaming module to function as it should.

The idea of the ModH264Streaming module is to be able to advance to any point in a video timeline before that part of the video has downloaded, but when I advance to half way (or wherever) the video always starts at the beginning even though the timeline indicator advances to the time that I have selected.

My server uses IIS7 32 bit, so I followed the instructions set out at this page... http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Internet-Information-Services-IIS7-Version2

The guys at Longtail have confirmed that my JWPlayer is installed and configured correctly.

I noticed the ModH264Streaming was DISABLED in IIS Handler Mapping, but allowing Execute in 'Edit Feature Permission' made it enabled. This instruction is missing from the documentation.

What information do you need to help me fix this issue?

Thanks in advance, Hush

  • Message #1109

    Hi,

    The first thing to check is whether the MP4 video gets served by the module. You can check this using 'wget':

    wget -S -O test.mp4 "http://h264-demo.code-shop.com/demo/apache/trailer2.mp4"
    

    and look for the response header similar to:

    X-Mod-H264-Streaming: version=x.y.zz
    

    Is this line in the output?

    Regards,

    • Message #1111

      Hi Arjen,

      My results are in the next post.

      Until today, I had never heard of WGET. Finding the right way to install WGET with Windows 7 was a bit tricky to find, so here are some instructions that might help others...

      HOW TO INSTALL WGET ON WINDOWS 7: Download wget.exe from http://users.ugent.be/~bpuype/wget/ Save wget.exe to the root of your Windows\System32 folder

      WGET is now installed and ready to be used.

      HOW TO USE WGET: Open Command Prompt (Start>Run> type 'cmd' [click OK]) Now type in the command Arjen has provided above and hit Enter to run the test.

      Hush

    • Message #1112

      My results...

      C:>wget -S -O test.mp4 "http://h264-demo.code-shop.com/demo/apache/trailer2.mp4" --2011-09-02 08:17:59-- http://h264-demo.code-shop.com/demo/apache/trailer2.mp4

      Resolving h264-demo.code-shop.com... 82.94.203.240
      Connecting to h264-demo.code-shop.com|82.94.203.240|:80... connected.
      HTTP request sent, awaiting response...
        HTTP/1.0 200 OK
        X-Mod-H264-Streaming: version=2.4.29
        Last-Modified: Fri, 22 Jul 2011 09:04:50 GMT
        Content-Type: video/mp4
        ETag: "-720905980"
        Content-Length: 43678265
        Connection: keep-alive
        Date: Thu, 01 Sep 2011 22:18:45 GMT
        Server: lighttpd/1.5.0
      Length: 43678265 (42M) [video/mp4]
      Saving to: `test.mp4'
      

      Hush

      • Reply:



      • Message #1114

        Hi Hush,

        You have to change the URL to point to your own server. You can also look at the output from your next mesasage, but you have to add the '-S' switch to the commandline:

        wget -S -O file.mp4 "http://xxxxxx.com/file.mp4?start=45.5"
        

        Regards,

        • Message #1116

          Hi Arjen,

          Thanks for noticing my mistake and thanks for your ongoing support.

          I did use my own domain for the last test, but I removed my server details from the results. Same again with the test below.

          Unfortunately the downloaded video did not have the first 45.5 seconds removed. The full file was downloaded.

          So does this mean the installation of the module is not correct? I can send screenshots of the relevant IIS installation if it may help.

          Hush

          C:\Users\####>wget -S -O file.mp4 "http://www.#######.com/file.mp4?start=45.5"
          --2011-09-05 07:57:57--  http://www.#######.com/file.mp4?start=45.5
          Resolving www.#######.com... ###.###.###.###
          Connecting to www.#######.com|###.###.###.###|:80... connected.
          HTTP request sent, awaiting response...
            HTTP/1.1 200 OK
            Content-Type: video/mp4
            Last-Modified: Mon, 29 Aug 2011 03:10:21 GMT
            Accept-Ranges: bytes
            ETag: "acb83830f965cc1:0"
            Server: Microsoft-IIS/7.0
            X-Powered-By: ASP.NET
            Date: Sun, 04 Sep 2011 21:59:35 GMT
            Connection: keep-alive
            Content-Length: 15812222
          Length: 15812222 (15M) [video/mp4]
          Saving to: `file.mp4'
          100%[======================================>] 15,812,222   251K/s   in 62s
          2011-09-05 07:58:59 (248 KB/s) - `file.mp4' saved [15812222/15812222]
          

          Mediainfo details for file.mp4

          General
          Complete name                    : C:\Users\####\file.mp4
          Format                           : MPEG-4
          Format profile                   : Base Media
          Codec ID                         : isom
          File size                        : 15.1 MiB
          Duration                         : 3mn 58s
          Overall bit rate                 : 531 Kbps
          Movie name                       : ######
          Writing application              : Lavf52.108.0
          Video
          ID                               : 1
          Format                           : AVC
          Format/Info                      : Advanced Video Codec
          Format profile                   : High@L3.0
          Format settings, CABAC           : Yes
          Format settings, ReFrames        : 4 frames
          Codec ID                         : avc1
          Codec ID/Info                    : Advanced Video Coding
          Duration                         : 3mn 58s
          Bit rate                         : 400 Kbps
          Width                            : 640 pixels
          Height                           : 480 pixels
          Display aspect ratio             : 4:3
          Frame rate mode                  : Constant
          Frame rate                       : 30.000 fps
          Color space                      : YUV
          Chroma subsampling               : 4:2:0
          Bit depth                        : 8 bits
          Scan type                        : Progressive
          Bits/(Pixel*Frame)               : 0.043
          Stream size                      : 11.3 MiB (75%)
          Writing library                  : x264 core 115 r1947 b5a8ad7
          Encoding settings                : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=400 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
          Tagged date                      : UTC 2011-08-28 02:54:48
          Audio
          ID                               : 2
          Format                           : AAC
          Format/Info                      : Advanced Audio Codec
          Format profile                   : LC
          Codec ID                         : 40
          Duration                         : 3mn 58s
          Bit rate mode                    : Constant
          Bit rate                         : 128 Kbps
          Channel(s)                       : 2 channels
          Channel positions                : Front: L R
          Sampling rate                    : 48.0 KHz
          Compression mode                 : Lossy
          Stream size                      : 3.63 MiB (24%)
          Tagged date                      : UTC 2011-08-28 02:54:48
          
    • Message #1113

      Hi Arjen,

      I tried the following test at http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Testing-Version2

      The downloaded file was the full file - it did not remove the first 45.5 seconds as it should have.

      Does this mean the installation was not successful? What can we do to fix it?

      Hush

      C:>wget -O file.mp4 "http://xxxxxx.com/file.mp4?start=45.5"
      --2011-09-02 08:55:21--  http://xxxxxx.com/file.mp4?start=45.5
      Resolving server.com... xxx.xxx.xxx.xxx
      Connecting to xxxxxx.com|xxx.xxx.xxx.xxx|:80... connected.
      HTTP request sent, awaiting response... 200 OK
      Length: 15812222 (15M) [video/mp4]
      Saving to: `file.mp4'
      100%[======================================>] 15,812,222   760K/s   in 25s
      2011-09-02 08:55:46 (626 KB/s) - `file.mp4' saved [15812222/15812222]
      
      • Message #1118

        I had issues myself, at first, with 32bit on 64bit (Windows 2008 R2 Sp1 x64) but got it all working when I double checked every setting from scratch... can you verify your app pool is running the and dll isn't triggering errors in the application event log?

        That was my first problem to address.

        Talk soon.

        Dan

        • Message #1119

          Hi Dan,

          Thanks for your assistance.

          I'm a bit of a noob when it comes to IIS7, but I checked the application Event Logs and there are no errors. I also checked the list of application pools but all I can see in there are my domain names and they're all running normally.

          I did try starting from scratch, but it didn't fix it. I am certain I followed the instructions correctly both times.

          We'll see what Arjen has to suggest, then, if all else fails I'll provide some screenshots of my IIS settings and module folder location, etc...

          Cheers! Hush

          • Message #1122

            Hi,

            The module is not serving your files, so it must be a configuration issue. Verifying IIS configurations is a bit tricky, but if you could post some screenshots that will help.

            Regards,

            • Message #1123

              Hi Arjen,

              I need to send these in 2 separate posts due to your anti-spam settings.

              PART 1

              Module location (for IIS7 32bit) http://www.billarga.com/A-Explorer-DLL_Location.jpg

              Handler Mappings http://www.billarga.com/B-Hander_Mappings.jpg

              Module Mapping http://www.billarga.com/C-Module_Mapping.jpg

            • Message #1124

              PART 2

              Edit Module Mapping http://www.billarga.com/D-Edit_Module_Mapping.jpg

              Request Restrictions - Mapping Tab http://www.billarga.com/E-Request_Restrictions-Mapping.jpg

              Request Restrictions - Verbs Tab http://www.billarga.com/F-Request_Restrictions-Verbs.jpg

              Request Restrictions - Access Tab http://www.billarga.com/G-Request_Restrictions-Access.jpg

              Hush

            • Message #1125

              Note: You will see in my last screenshot that I have Access set to 'Execute', but I have since changed it to 'Scripts' in accordance with the change you made recently in the documentation. I had already previously tried both options without any success.

              Set 'Access' to 'Scripts'. (Note to self: verify why this was previously 'Execute').
              

              I tried the wget again and it didn't remove the first 45.5 seconds.

              Hush

              • Message #1126

                Hi Hush,

                You are setting the Request Path to '*.mp4, *.flv'. I am not sure if IIS allows multiple specifications. Try setting it to '*.mp4'.

                Hope this helps,

                Arjen

                • Message #1127

                  Hi Arjen,

                  Yes, it helped, thanks! By removing flv it now works as it should.

                  I blame microsoft for using two files separated by comma in their example Request Path :D

                  I have had to recode my site so the MP4 files are loaded into the JWP, instead of the FLVs (was a legacy issue from a time long before MP4 was thought of), but that was simple enough.

                  Thanks so much for your help and for the awesome codework!

                  Thanks also to Dan for your help...you were also right.

                  Hush

                  • Message #1128

                    Dan,

                    As a side note, you were correct to suggest that restarting from scratch can also fix the problem for II7. I had the same incorrect settings on another mirror server. Editing the existing settings didn't work at all. It worked only after removing all ModH264Streaming settings from IIS and starting over.

                    Thanks! Hush

Attachments

No attachments created.